Skip to content

← Actionable
Medium, CVSS 4.8

tablib: Stored XSS in the HTML export via unescaped dataset title

CVE-2026-9318GHSA-gqgw-jghv-mxwx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tablib 3.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tablib

    Affected
    < 3.10.0
    Fixed in
    3.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-9318: 0.30% estimated exploitation activity in the next 30 days; percentile 22.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

tablib prior to 3.10.0 contains a stored cross-site scripting vulnerability in the HTML export functionality that allows attackers to execute arbitrary JavaScript by embedding malicious payloads in dataset titles, which are interpolated unsanitized into HTML output via the exportbook method in the html.py format handler. Attackers can rename worksheet sheets in imported files such as XLSX, ODS, XLS, or YAML with script payloads that are assigned to the Dataset title attribute and rendered unescaped inside an HTML h3 tag, leading to session hijacking, unauthorized administrative actions, and sensitive data exposure when the output is rendered in a browser.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gqgw-jghv-mxwx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-9318

Advisory: tablib: Stored XSS in the HTML export via unescaped dataset title
IDs: CVE-2026-9318, GHSA-gqgw-jghv-mxwx
Record: https://patchnext.com/advisories/cve-2026-9318 (revision 1, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tablib 3.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tablib: affected < 3.10.0; fixed in 3.10.0

## Suggested inspection (read-only)
- `python -m pip show tablib`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tablib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gqgw-jghv-mxwx (GitHub-reviewed advisory GHSA-gqgw-jghv-mxwx lists affected ranges: PyPI tablib >=0 <3.10.0)

Commands are suggestions: review each one before running it.

Loading voting…