Medium, CVSS 5.9PyPIAmendedPublished
simplejson before 2.6.1 vulnerable to array index error
CVE-2014-4616 · GHSA-9772-cwx9-r4cj
- Affected
- PyPI simplejson < 2.6.1
- Fixed in
- 2.6.1· Vendor fix available
- Issue
- Array index error in the scanstring function in the json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the rawdecode function.
Recommended action: Upgrade to 2.6.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.