Skip to content

← Actionable
Medium, CVSS 5.9amended

simplejson before 2.6.1 vulnerable to array index error

CVE-2014-4616GHSA-9772-cwx9-r4cj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simplejson 2.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2014-4616: 7.85% estimated exploitation activity in the next 30 days; percentile 94.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Array index error in the scanstring function in the json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the rawdecode function.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9772-cwx9-r4cj

  2. Revision 1 · created ·

    Published from osv record GHSA-9772-cwx9-r4cj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-4616

Advisory: simplejson before 2.6.1 vulnerable to array index error
IDs: CVE-2014-4616, GHSA-9772-cwx9-r4cj
Record: https://patchnext.com/advisories/cve-2014-4616 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simplejson 2.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI simplejson: affected < 2.6.1; fixed in 2.6.1

## Suggested inspection (read-only)
- `python -m pip show simplejson`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simplejson.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9772-cwx9-r4cj (OSV record GHSA-9772-cwx9-r4cj lists affected ranges: PyPI simplejson >=0 <2.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-9772-cwx9-r4cj (GitHub-reviewed advisory GHSA-9772-cwx9-r4cj lists affected ranges: PyPI simplejson >=0 <2.6.1)

Commands are suggestions: review each one before running it.

Loading voting…