Skip to content

← Public intelligence

PyPI package

shuup

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1PyPIAmendedPublished

    Cross-site Scripting in shuup

    CVE-2021-25963 · GHSA-5pcx-vqjp-p34w

    Affected
    • PyPI shuup >= 1.6.0, < 2.11.0
    Fixed in
    2.11.0· Vendor fix available
    Issue
    In Shuup, versions 1.6.0 through 2.10.8 are vulnerable to reflected Cross-Site Scripting (XSS) that allows execution of arbitrary javascript code on a victim browser. This vulnerability exists due to the error page contents not escaped.

    Recommended action: Upgrade to 2.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.0PyPIAmendedPublished

    CSV injection in shuup

    CVE-2021-25962 · GHSA-663j-rjcr-789f

    Affected
    • PyPI shuup >= 0.4.2, < 2.11.0
    Fixed in
    2.11.0· Vendor fix available
    Issue
    “Shuup” application in versions 0.4.2 to 2.10.8 is affected by the “Formula Injection” vulnerability. A customer can inject payloads in the name input field in the billing address while buying a product. When a store administrator accesses the reports page to export the data as an Excel file and opens it, the payload gets executed.

    Recommended action: Upgrade to 2.11.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →