Skip to content

← Actionable
High, CVSS 8.0amended

CSV injection in shuup

CVE-2021-25962GHSA-663j-rjcr-789f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shuup 2.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI shuup

    Affected
    >= 0.4.2, < 2.11.0
    Fixed in
    2.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-25962: 1.09% estimated exploitation activity in the next 30 days; percentile 65.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

“Shuup” application in versions 0.4.2 to 2.10.8 is affected by the “Formula Injection” vulnerability. A customer can inject payloads in the name input field in the billing address while buying a product. When a store administrator accesses the reports page to export the data as an Excel file and opens it, the payload gets executed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-663j-rjcr-789f

  2. Revision 1 · created ·

    Published from osv record GHSA-663j-rjcr-789f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-25962

Advisory: CSV injection in shuup
IDs: CVE-2021-25962, GHSA-663j-rjcr-789f
Record: https://patchnext.com/advisories/cve-2021-25962 (revision 2, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shuup 2.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI shuup: affected >= 0.4.2, < 2.11.0; fixed in 2.11.0

## Suggested inspection (read-only)
- `python -m pip show shuup`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shuup.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-663j-rjcr-789f (OSV record GHSA-663j-rjcr-789f lists affected ranges: PyPI shuup >=0.4.2 <2.11.0 (fixed))
- Verified: https://github.com/advisories/GHSA-663j-rjcr-789f (GitHub-reviewed advisory GHSA-663j-rjcr-789f lists affected ranges: PyPI shuup >=0.4.2 <2.11.0)

Commands are suggestions: review each one before running it.

Loading voting…