Critical, CVSS 9.3PyPIAmendedPublished
Recurly vulnerable to SSRF
CVE-2017-0906 · GHSA-38rv-5jqc-m2cv
- Affected
- PyPI recurly >= 2.6.0, < 2.6.2; >= 2.5.0, <= 2.5.0; >= 2.4.0, < 2.4.5; >= 2.3.0, <= 2.3.0; >= 2.2.0, < 2.2.22; >= 2.1.0, < 2.1.16; < 2.0.5
- Fixed in
- 2.4.52.1.162.5.12.2.222.0.52.6.22.3.1· Vendor fix available
- Issue
- The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the Resource.get method that could result in compromise of API keys or other critical resources.
Recommended action: Upgrade to 2.6.2, 2.5.1, 2.4.5 or 4 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.