Recurly vulnerable to SSRF
CVE-2017-0906GHSA-38rv-5jqc-m2cv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (recurly 2.6.2, 2.5.1, 2.4.5, 2.3.1, 2.2.22, 2.1.16, 2.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI recurly
- Affected
- >= 2.6.0, < 2.6.2>= 2.5.0, <= 2.5.0>= 2.4.0, < 2.4.5>= 2.3.0, <= 2.3.0>= 2.2.0, < 2.2.22>= 2.1.0, < 2.1.16< 2.0.5
- Fixed in
- 2.4.5, 2.1.16, 2.5.1, 2.2.22, 2.0.5, 2.6.2, 2.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-38rv-5jqc-m2cv lists affected ranges: PyPI recurly >=2.6.0 =2.5.0 =2.4.0 =2.3.0 =2.2.0 =2.1.0 =0 <2.0.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-38rv-5jqc-m2cv lists affected ranges: PyPI recurly >=2.6.0 =2.5.0 =2.4.0 =2.3.0 =2.2.0 =2.1.0 =0 <2.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2017-0906: 2.62% estimated exploitation activity in the next 30 days; percentile 85.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the Resource.get method that could result in compromise of API keys or other critical resources.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-38rv-5jqc-m2cv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-38rv-5jqc-m2cv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-0906 Advisory: Recurly vulnerable to SSRF IDs: CVE-2017-0906, GHSA-38rv-5jqc-m2cv Record: https://patchnext.com/advisories/cve-2017-0906 (revision 3, source checked 26 Oct 2026, 13:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: recurly 2.6.2, 2.5.1, 2.4.5, 2.3.1, 2.2.22, 2.1.16, 2.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI recurly: affected >= 2.6.0, < 2.6.2; >= 2.5.0, <= 2.5.0; >= 2.4.0, < 2.4.5; >= 2.3.0, <= 2.3.0; >= 2.2.0, < 2.2.22; >= 2.1.0, < 2.1.16; < 2.0.5; fixed in 2.4.5, 2.1.16, 2.5.1, 2.2.22, 2.0.5, 2.6.2, 2.3.1 ## Suggested inspection (read-only) - `python -m pip show recurly`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on recurly. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-38rv-5jqc-m2cv (OSV record GHSA-38rv-5jqc-m2cv lists affected ranges: PyPI recurly >=2.6.0 =2.5.0 =2.4.0 =2.3.0 =2.2.0 =2.1.0 =0 <2.0.5 (fixed)) - Verified: https://github.com/advisories/GHSA-38rv-5jqc-m2cv (GitHub-reviewed advisory GHSA-38rv-5jqc-m2cv lists affected ranges: PyPI recurly >=2.6.0 =2.5.0 =2.4.0 =2.3.0 =2.2.0 =2.1.0 =0 <2.0.5) Commands are suggestions: review each one before running it.
Loading voting…