Skip to content

← Public intelligence

PyPI package

readthedocs-sphinx-search

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3PyPIAmendedPublished

    readthedocs-sphinx-search vulnerable to cross-site scripting when including search results from malicious projects

    GHSA-xgfm-fjx6-62mj

    Affected
    • PyPI readthedocs-sphinx-search <= 0.3.1
    Fixed in
    0.3.2· Vendor fix available
    Issue
    Impact This vulnerability could have allowed an attacker to include arbitrary HTML content in search results by having a user search a malicious project. This was due to our search client not correctly escaping all user content from search results. You can find more information in the advisory published in our readthedocs.org repo. Users of this extension should update to the 0.3.2 version, and trigger a new build. This issue was discovered by a member of our team, and we have seen no signs that this vulnerability was exploited in the wild. Patches This issue has been patched in our 0.3.2 version. References - https://github.com/readthedocs/readthedocs-sphinx-search/commit/8c6f6d01e88e72ef32ed0c220b6c19d1e1121c73 For more information If you have any questions or comments about this advisory, email us at security@readthedocs.org (PGP)

    Recommended action: Upgrade to 0.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →