readthedocs-sphinx-search vulnerable to cross-site scripting when including search results from malicious projects
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (readthedocs-sphinx-search 0.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI readthedocs-sphinx-search
- Affected
- <= 0.3.1
- Fixed in
- 0.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xgfm-fjx6-62mj lists affected ranges: PyPI readthedocs-sphinx-search >=0 <0.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xgfm-fjx6-62mj lists affected ranges: PyPI readthedocs-sphinx-search >=0 <=0.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact This vulnerability could have allowed an attacker to include arbitrary HTML content in search results by having a user search a malicious project. This was due to our search client not correctly escaping all user content from search results. You can find more information in the advisory published in our readthedocs.org repo. Users of this extension should update to the 0.3.2 version, and trigger a new build. This issue was discovered by a member of our team, and we have seen no signs that this vulnerability was exploited in the wild. Patches This issue has been patched in our 0.3.2 version. References - https://github.com/readthedocs/readthedocs-sphinx-search/commit/8c6f6d01e88e72ef32ed0c220b6c19d1e1121c73 For more information If you have any questions or comments about this advisory, email us at security@readthedocs.org (PGP)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xgfm-fjx6-62mj
- Revision 1 · created ·
Published from osv record GHSA-xgfm-fjx6-62mj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-xgfm-fjx6-62mj Advisory: readthedocs-sphinx-search vulnerable to cross-site scripting when including search results from malicious projects IDs: GHSA-xgfm-fjx6-62mj Record: https://patchnext.com/advisories/ghsa-xgfm-fjx6-62mj (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: readthedocs-sphinx-search 0.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI readthedocs-sphinx-search: affected <= 0.3.1; fixed in 0.3.2 ## Suggested inspection (read-only) - `python -m pip show readthedocs-sphinx-search`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on readthedocs-sphinx-search. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xgfm-fjx6-62mj (OSV record GHSA-xgfm-fjx6-62mj lists affected ranges: PyPI readthedocs-sphinx-search >=0 <0.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-xgfm-fjx6-62mj (GitHub-reviewed advisory GHSA-xgfm-fjx6-62mj lists affected ranges: PyPI readthedocs-sphinx-search >=0 <=0.3.1) Commands are suggestions: review each one before running it.
Loading voting…