Skip to content

← Public intelligence

PyPI package

rasa-pro

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5PyPIAmendedPublished

    Rasa Pro Missing Authentication For Voice Connector APIs

    CVE-2025-32377 · GHSA-7xq5-54jp-2mfg

    Affected
    • PyPI rasa-pro >= 3.12.0, <= 3.12.5; >= 3.11.0, <= 3.11.6; >= 3.10.0, <= 3.10.18; <= 3.9.17
    Fixed in
    3.11.73.9.203.12.63.10.19· Vendor fix available
    Issue
    Vulnerability A vulnerability has been identified in Rasa Pro where voice connectors in Rasa Pro do not properly implement authentication even when a token is configured in the credentials.yml file. This could allow an attacker to submit voice data to the Rasa Pro assistant from an unauthenticated source. This impacts the following connectors: - audiocodesstream - genesys - jambonz As part of our investigation to resolve this issue, we have also performed a security review of our other voice channel connectors: - browseraudio: Does not support authentication. This is a development channel not intended for production use. - twiliomediastreams, twiliovoice and jambonz: Authentication is currently not supported by these channels, but our investigation has found a way for us to enable it for these voice channel connectors in a future Rasa Pro release. Fix The issue has been resolved for audiocodes, audiocodesstream, and genesys connectors. Fixed versions of Rasa Pro have been released…

    Recommended action: Upgrade to 3.12.6, 3.11.7, 3.10.19 or 3.9.20 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.0PyPIAmendedPublished

    Rasa Allows Remote Code Execution via Remote Model Loading

    CVE-2024-49375 · GHSA-cpv4-ggrr-7j9v

    Affected
    • PyPI rasa-pro >= 3.10.0, < 3.10.12; >= 3.9.0, < 3.9.16; < 3.8.18
    Fixed in
    3.9.163.8.183.10.12· Vendor fix available
    Issue
    Vulnerability A vulnerability has been identified in Rasa Pro and Rasa Open Source that enables an attacker who has the ability to load a maliciously crafted model remotely into a Rasa instance to achieve Remote Code Execution. The prerequisites for this are: - The HTTP API must be enabled on the Rasa instance eg with --enable-api. This is not the default configuration. - For unauthenticated RCE to be exploitable, the user must not have configured any authentication or other security controls recommended in our documentation. - For authenticated RCE, the attacker must posses a valid authentication token or JWT to interact with the Rasa API. Fix We encourage you to upgrade to a version of Rasa that includes a fix. These are: - Rasa Pro 3.8.18, 3.9.16, 3.10.12 - Rasa Open Source 3.6.21 Once you have upgraded your Rasa Pro or Open Source installation, you will need to retrain your model using the fixed version of Rasa Pro or Open Source. If you have a custom component that inherits from…

    Recommended action: Upgrade to 3.10.12, 3.9.16 or 3.8.18 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →