Rasa Pro Missing Authentication For Voice Connector APIs
CVE-2025-32377GHSA-7xq5-54jp-2mfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rasa-pro 3.12.6, 3.11.7, 3.10.19, 3.9.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI rasa-pro
- Affected
- >= 3.12.0, <= 3.12.5>= 3.11.0, <= 3.11.6>= 3.10.0, <= 3.10.18<= 3.9.17
- Fixed in
- 3.11.7, 3.9.20, 3.12.6, 3.10.19
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7xq5-54jp-2mfg lists affected ranges: PyPI rasa-pro >=3.12.0 =3.11.0 =3.10.0 =0 <3.9.20 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7xq5-54jp-2mfg lists affected ranges: PyPI rasa-pro >=3.12.0 =3.11.0 =3.10.0 =0 <=3.9.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- EPSS
- CVE-2025-32377: 0.47% estimated exploitation activity in the next 30 days; percentile 40.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Vulnerability A vulnerability has been identified in Rasa Pro where voice connectors in Rasa Pro do not properly implement authentication even when a token is configured in the credentials.yml file. This could allow an attacker to submit voice data to the Rasa Pro assistant from an unauthenticated source. This impacts the following connectors: - audiocodesstream - genesys - jambonz As part of our investigation to resolve this issue, we have also performed a security review of our other voice channel connectors: - browseraudio: Does not support authentication. This is a development channel not intended for production use. - twiliomediastreams, twiliovoice and jambonz: Authentication is currently not supported by these channels, but our investigation has found a way for us to enable it for these voice channel connectors in a future Rasa Pro release. Fix The issue has been resolved for audiocodes, audiocodesstream, and genesys connectors. Fixed versions of Rasa Pro have been released…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7xq5-54jp-2mfg
- Revision 1 · created ·
Published from osv record GHSA-7xq5-54jp-2mfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32377 Advisory: Rasa Pro Missing Authentication For Voice Connector APIs IDs: CVE-2025-32377, GHSA-7xq5-54jp-2mfg Record: https://patchnext.com/advisories/cve-2025-32377 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rasa-pro 3.12.6, 3.11.7, 3.10.19, 3.9.20. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI rasa-pro: affected >= 3.12.0, <= 3.12.5; >= 3.11.0, <= 3.11.6; >= 3.10.0, <= 3.10.18; <= 3.9.17; fixed in 3.11.7, 3.9.20, 3.12.6, 3.10.19 ## Suggested inspection (read-only) - `python -m pip show rasa-pro`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rasa-pro. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7xq5-54jp-2mfg (OSV record GHSA-7xq5-54jp-2mfg lists affected ranges: PyPI rasa-pro >=3.12.0 =3.11.0 =3.10.0 =0 <3.9.20 (fixed)) - Verified: https://github.com/advisories/GHSA-7xq5-54jp-2mfg (GitHub-reviewed advisory GHSA-7xq5-54jp-2mfg lists affected ranges: PyPI rasa-pro >=3.12.0 =3.11.0 =3.10.0 =0 <=3.9.17) Commands are suggestions: review each one before running it.
Loading voting…