Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
Vulnerability A vulnerability has been identified in Rasa Pro and Rasa Open Source that enables an attacker who has the ability to load a maliciously crafted model remotely into a Rasa instance to achieve Remote Code Execution. The prerequisites for this are: - The HTTP API must be enabled on the Rasa instance eg with --enable-api. This is not the default configuration. - For unauthenticated RCE to be exploitable, the user must not have configured any authentication or other security controls recommended in our documentation. - For authenticated RCE, the attacker must posses a valid authentication token or JWT to interact with the Rasa API. Fix We encourage you to upgrade to a version of Rasa that includes a fix. These are: - Rasa Pro 3.8.18, 3.9.16, 3.10.12 - Rasa Open Source 3.6.21 Once you have upgraded your Rasa Pro or Open Source installation, you will need to retrain your model using the fixed version of Rasa Pro or Open Source. If you have a custom component that inherits from…
Recommended action: Upgrade to 3.6.21 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Impact An Archive Extraction (Zip Slip) vulnerability in the functionality that allows a user to load a trained model archive in Rasa 2.8.9 and older allows an attacker arbitrary write capability within specific directories using a malicious crafted archive file. Patches The vulnerability is fixed in Rasa 2.8.10 Workarounds Mitigating steps for vulnerable end users are to ensure that they do not upload untrusted model files, and restrict CLI or API endpoint access where a malicious actor could target a deployed Rasa instance. For more information If you have any questions or comments about this advisory: Email the Rasa Security Team
Recommended action: Upgrade to 2.8.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.