Maliciously Crafted Model Archive Can Lead To Arbitrary File Write
CVE-2021-41127GHSA-4365-fhm5-qcrx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rasa 2.8.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI rasa
- Affected
- < 2.8.10
- Fixed in
- 2.8.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4365-fhm5-qcrx lists affected ranges: PyPI rasa >=0 <2.8.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4365-fhm5-qcrx lists affected ranges: PyPI rasa >=0 <2.8.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:H
- EPSS
- CVE-2021-41127: 0.76% estimated exploitation activity in the next 30 days; percentile 55.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An Archive Extraction (Zip Slip) vulnerability in the functionality that allows a user to load a trained model archive in Rasa 2.8.9 and older allows an attacker arbitrary write capability within specific directories using a malicious crafted archive file. Patches The vulnerability is fixed in Rasa 2.8.10 Workarounds Mitigating steps for vulnerable end users are to ensure that they do not upload untrusted model files, and restrict CLI or API endpoint access where a malicious actor could target a deployed Rasa instance. For more information If you have any questions or comments about this advisory: Email the Rasa Security Team
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4365-fhm5-qcrx
- Revision 1 · created ·
Published from osv record GHSA-4365-fhm5-qcrx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-41127 Advisory: Maliciously Crafted Model Archive Can Lead To Arbitrary File Write IDs: CVE-2021-41127, GHSA-4365-fhm5-qcrx Record: https://patchnext.com/advisories/cve-2021-41127 (revision 2, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rasa 2.8.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI rasa: affected < 2.8.10; fixed in 2.8.10 ## Suggested inspection (read-only) - `python -m pip show rasa`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rasa. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4365-fhm5-qcrx (OSV record GHSA-4365-fhm5-qcrx lists affected ranges: PyPI rasa >=0 <2.8.10 (fixed)) - Verified: https://github.com/advisories/GHSA-4365-fhm5-qcrx (GitHub-reviewed advisory GHSA-4365-fhm5-qcrx lists affected ranges: PyPI rasa >=0 <2.8.10) Commands are suggestions: review each one before running it.
Loading voting…