Skip to content

← Public intelligence

PyPI package

pyyaml

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.3PyPIAmendedPublished

    Deserialization of Untrusted Data in PyYAML

    CVE-2019-20477 · GHSA-3pqx-4fqf-j49f

    Affected
    • PyPI pyyaml >= 5.1, < 5.2
    Fixed in
    5.2· Vendor fix available
    Issue
    PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and loadall functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.

    Recommended action: Upgrade to 5.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.3PyPIAmendedPublished

    Improper Input Validation in PyYAML

    CVE-2020-1747 · GHSA-6757-jp84-gxfx

    Affected
    • PyPI pyyaml >= 5.1b7, < 5.3.1
    Fixed in
    5.3.1· Vendor fix available
    Issue
    A vulnerability was discovered in the PyYAML library in versions before 5.3.1, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the fullload method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. An attacker could use this flaw to execute arbitrary code on the system by abusing the python/object/new constructor.

    Recommended action: Upgrade to 5.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.3PyPIAmendedPublished

    Improper Input Validation in PyYAML

    CVE-2020-14343 · GHSA-8q59-q68h-6hv4

    Affected
    • PyPI pyyaml < 5.4
    Fixed in
    5.4· Vendor fix available
    Issue
    A vulnerability was discovered in the PyYAML library in versions before 5.4, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the fullload method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. This flaw allows an attacker to execute arbitrary code on the system by abusing the python/object/new constructor. This flaw is due to an incomplete fix for CVE-2020-1747.

    Recommended action: Upgrade to 5.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Critical, CVSS 9.8PyPIAmendedPublished

    PyYAML insecurely deserializes YAML strings leading to arbitrary code execution

    CVE-2017-18342 · GHSA-rprw-h62v-c2w7

    Affected
    • PyPI pyyaml < 5.1
    Fixed in
    5.1· Vendor fix available
    Issue
    In PyYAML before 5.1, the yaml.load() API could execute arbitrary code. In other words, yaml.safeload is not used. This was intended to be fixed in 4.1, but due to breaking changes, 4.1 was yanked and 5.1 contains the patch for CVE-2017-18342.

    Recommended action: Upgrade to 5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →