Skip to content

← Actionable
Critical, CVSS 9.8amended

PyYAML insecurely deserializes YAML strings leading to arbitrary code execution

CVE-2017-18342GHSA-rprw-h62v-c2w7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyyaml 5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyyaml

    Affected
    < 5.1
    Fixed in
    5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2017-18342: 5.57% estimated exploitation activity in the next 30 days; percentile 92.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In PyYAML before 5.1, the yaml.load() API could execute arbitrary code. In other words, yaml.safeload is not used. This was intended to be fixed in 4.1, but due to breaking changes, 4.1 was yanked and 5.1 contains the patch for CVE-2017-18342.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rprw-h62v-c2w7

  2. Revision 1 · created ·

    Published from osv record GHSA-rprw-h62v-c2w7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-18342

Advisory: PyYAML insecurely deserializes YAML strings leading to arbitrary code execution
IDs: CVE-2017-18342, GHSA-rprw-h62v-c2w7
Record: https://patchnext.com/advisories/cve-2017-18342 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyyaml 5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyyaml: affected < 5.1; fixed in 5.1

## Suggested inspection (read-only)
- `python -m pip show pyyaml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyyaml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rprw-h62v-c2w7 (OSV record GHSA-rprw-h62v-c2w7 lists affected ranges: PyPI pyyaml >=0 <5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-rprw-h62v-c2w7 (GitHub-reviewed advisory GHSA-rprw-h62v-c2w7 lists affected ranges: PyPI pyyaml >=0 <5.1)

Commands are suggestions: review each one before running it.

Loading voting…