Skip to content

← Public intelligence

PyPI package

pytorch-lightning

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.4PyPIAmendedPublished

    PyTorch Lightning allows arbitrary code execution through checkpoint _instantiator hyperparameters

    CVE-2026-58659 · GHSA-qqmf-gpg7-g8gw

    Affected
    • PyPI pytorch-lightning < 2.6.6
    Fixed in
    2.6.6· Vendor fix available
    Issue
    PyTorch Lightning through 2.6.5, fixed in commit d710d68, contains a remote code execution vulnerability in the loadstate function that imports and executes attacker-controlled module names from checkpoint instantiator hyperparameters. Attackers can craft malicious checkpoint files that bypass weightsonly=True protections to execute arbitrary code when LightningModule.loadfromcheckpoint is called.

    Recommended action: Upgrade to 2.6.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)osv.dev (2)github.com (3)Source checked Evidence →
  2. Critical, CVSS 9.1PyPIAmendedPublished

    PyTorch Lightning path traversal vulnerability

    CVE-2024-8019 · GHSA-4cv3-v7pv-rfhf

    Affected
    • PyPI pytorch-lightning < 2.4.0
    Fixed in
    2.4.0· Vendor fix available
    Issue
    In lightning-ai/pytorch-lightning version 2.3.2, a vulnerability exists in the LightningApp when running on a Windows host. The vulnerability occurs at the /api/v1/uploadfile/ endpoint, allowing an attacker to write or overwrite arbitrary files by providing a crafted filename. This can lead to potential remote code execution (RCE) by overwriting critical files or placing malicious files in sensitive locations.

    Recommended action: Upgrade to 2.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.3PyPIAmendedPublished

    Code Injection in PyTorch Lightning

    CVE-2022-0845 · GHSA-r5qj-cvf9-p85h

    Affected
    • PyPI pytorch-lightning < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    PyTorch Lightning version 1.5.10 and prior is vulnerable to code injection. An attacker could execute commands on the target OS running the operating system by setting the PLTRAINERGPUS when using the Trainer module. A patch is included in the 1.6.0 release.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. High, CVSS 8.5PyPIAmendedPublished

    pytorch-lightning is vulnerable to Deserialization of Untrusted Data

    CVE-2021-4118 · GHSA-2vj5-px25-gjrp

    Affected
    • PyPI pytorch-lightning < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    pytorch-lightning is vulnerable to Deserialization of Untrusted Data.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →