PyTorch Lightning allows arbitrary code execution through checkpoint _instantiator hyperparameters
CVE-2026-58659GHSA-qqmf-gpg7-g8gw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pytorch-lightning 2.6.6; lightning 2.6.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pytorch-lightning
- Affected
- < 2.6.6
- Fixed in
- 2.6.6
PyPI lightning
- Affected
- < 2.6.6
- Fixed in
- 2.6.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qqmf-gpg7-g8gw lists affected ranges: PyPI lightning >=0 <2.6.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-3967 lists affected ranges: PyPI pytorch-lightning >=0 <2.6.6 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qqmf-gpg7-g8gw lists affected ranges: PyPI lightning >=0 <2.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-58659: 0.63% estimated exploitation activity in the next 30 days; percentile 50.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
PyTorch Lightning through 2.6.5, fixed in commit d710d68, contains a remote code execution vulnerability in the loadstate function that imports and executes attacker-controlled module names from checkpoint instantiator hyperparameters. Attackers can craft malicious checkpoint files that bypass weightsonly=True protections to execute arbitrary code when LightningModule.loadfromcheckpoint is called.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-qqmf-gpg7-g8gw
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record PYSEC-2026-3967
- Revision 1 · created ·
Published from osv record GHSA-qqmf-gpg7-g8gw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-58659 Advisory: PyTorch Lightning allows arbitrary code execution through checkpoint _instantiator hyperparameters IDs: CVE-2026-58659, GHSA-qqmf-gpg7-g8gw Record: https://patchnext.com/advisories/cve-2026-58659 (revision 4, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pytorch-lightning 2.6.6; lightning 2.6.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pytorch-lightning: affected < 2.6.6; fixed in 2.6.6 - PyPI lightning: affected < 2.6.6; fixed in 2.6.6 ## Suggested inspection (read-only) - `python -m pip show pytorch-lightning`: prints the installed version. Run with the environment that serves production active. - `python -m pip show lightning`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pytorch-lightning, lightning. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qqmf-gpg7-g8gw (OSV record GHSA-qqmf-gpg7-g8gw lists affected ranges: PyPI lightning >=0 <2.6.6 (fixed)) - Verified: https://osv.dev/vulnerability/PYSEC-2026-3967 (OSV record PYSEC-2026-3967 lists affected ranges: PyPI pytorch-lightning >=0 <2.6.6 (fixed)) - Verified: https://github.com/advisories/GHSA-qqmf-gpg7-g8gw (GitHub-reviewed advisory GHSA-qqmf-gpg7-g8gw lists affected ranges: PyPI lightning >=0 <2.6.6) Commands are suggestions: review each one before running it.
Loading voting…