Skip to content

← Public intelligence

PyPI package

python-gnupg

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PyPIPublished

    Improper Input Validation python-gnupg

    CVE-2019-6690 · GHSA-2fch-jvg5-crf6

    Affected
    • PyPI python-gnupg < 0.4.4
    Fixed in
    0.4.4· Vendor fix available
    Issue
    python-gnupg 0.4.3 allows context-dependent attackers to trick gnupg to decrypt other ciphertext than intended. To perform the attack, the passphrase to gnupg must be controlled by the adversary and the ciphertext should be trusted. Related to a "CWE-20: Improper Input Validation" issue affecting the affect functionality component.

    Recommended action: Upgrade to 0.4.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  2. High, CVSS 8.7PyPIAmendedPublished

    python-gnupg's shell_quote function does not properly quote strings

    CVE-2014-1927 · GHSA-r3vr-prwv-86g9

    Affected
    • PyPI python-gnupg >= 0.3.5, <= 0.3.5
    Fixed in
    0.3.6· Vendor fix available
    Issue
    The shellquote function in python-gnupg 0.3.5 does not properly quote strings, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "$(" command-substitution sequences, a different vulnerability than CVE-2014-1928. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

    Recommended action: Upgrade to 0.3.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 8.1PyPIAmendedPublished

    python-gnupg allows context-dependent attackers to execute arbitrary commands via shell metacharacters

    CVE-2013-7323 · GHSA-c2fx-8r76-gh36

    Affected
    • PyPI python-gnupg < 0.3.7
    Fixed in
    0.3.7· Vendor fix available
    Issue
    python-gnupg before 0.3.5 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in unspecified vectors.

    Recommended action: Upgrade to 0.3.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  4. High, CVSS 8.7PyPIAmendedPublished

    python-gnupg's shell_quote function does not properly escape characters

    CVE-2014-1928 · GHSA-2jc8-4r6g-282j

    Affected
    • PyPI python-gnupg >= 0.3.5, <= 0.3.5
    Fixed in
    0.3.6· Vendor fix available
    Issue
    The shellquote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using "\" (backslash) characters to form multi-command sequences, a different vulnerability than CVE-2014-1927. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

    Recommended action: Upgrade to 0.3.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Critical, CVSS 9.3PyPIAmendedPublished

    python-gnupg vulnerable to shell injection

    CVE-2014-1929 · GHSA-vcr5-xr9h-mvc5

    Affected
    • PyPI python-gnupg >= 0.3.5, <= 0.3.6
    Fixed in
    0.3.7· Vendor fix available
    Issue
    python-gnupg 0.3.5 and 0.3.6 allow for shell injection via a failure to escape backslashes in the shellquote() function. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

    Recommended action: Upgrade to 0.3.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →