python-gnupg vulnerable to shell injection
CVE-2014-1929GHSA-vcr5-xr9h-mvc5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-gnupg 0.3.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI python-gnupg
- Affected
- >= 0.3.5, <= 0.3.6
- Fixed in
- 0.3.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vcr5-xr9h-mvc5 lists affected ranges: PyPI python-gnupg >=0.3.5 <0.3.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vcr5-xr9h-mvc5 lists affected ranges: PyPI python-gnupg >=0.3.5 <=0.3.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2014-1929: 0.39% estimated exploitation activity in the next 30 days; percentile 32.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
python-gnupg 0.3.5 and 0.3.6 allow for shell injection via a failure to escape backslashes in the shellquote() function. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-vcr5-xr9h-mvc5
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-vcr5-xr9h-mvc5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-1929 Advisory: python-gnupg vulnerable to shell injection IDs: CVE-2014-1929, GHSA-vcr5-xr9h-mvc5 Record: https://patchnext.com/advisories/cve-2014-1929 (revision 3, source checked 26 Oct 2026, 13:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-gnupg 0.3.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-gnupg: affected >= 0.3.5, <= 0.3.6; fixed in 0.3.7 ## Suggested inspection (read-only) - `python -m pip show python-gnupg`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-gnupg. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vcr5-xr9h-mvc5 (OSV record GHSA-vcr5-xr9h-mvc5 lists affected ranges: PyPI python-gnupg >=0.3.5 <0.3.7 (fixed)) - Verified: https://github.com/advisories/GHSA-vcr5-xr9h-mvc5 (GitHub-reviewed advisory GHSA-vcr5-xr9h-mvc5 lists affected ranges: PyPI python-gnupg >=0.3.5 <=0.3.6) Commands are suggestions: review each one before running it.
Loading voting…