Skip to content

← Public intelligence

PyPI package

python-cjson

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9PyPIAmendedPublished

    Improper Restriction of Operations within the Bounds of a Memory Buffer in python-cjson

    CVE-2010-1666 · GHSA-cqmh-mpx2-g633

    Affected
    • PyPI python-cjson <= 1.0.5
    Fixed in
    1.0.5.1· Vendor fix available
    Issue
    Buffer overflow in Dan Pascu python-cjson 1.0.5, when UCS-4 encoding is enabled, allows context-dependent attackers to cause a denial of service (application crash) or possibly have unspecified other impact via vectors involving crafted Unicode input to the cjson.encode function.

    Recommended action: Upgrade to 1.0.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.3PyPIAmendedPublished

    Cross-site Scripting in python-cjson

    CVE-2009-4924 · GHSA-95jp-77w6-qj52

    Affected
    • PyPI python-cjson < 1.1.0
    Fixed in
    1.1.0· Vendor fix available
    Issue
    Python-cjson 1.0.5 does not properly handle a ['/'] argument to cjson.encode, which makes it easier for remote attackers to conduct certain cross-site scripting (XSS) attacks involving Firefox and the end tag of a SCRIPT element.

    Recommended action: Upgrade to 1.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →