Improper Restriction of Operations within the Bounds of a Memory Buffer in python-cjson
CVE-2010-1666GHSA-cqmh-mpx2-g633
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-cjson 1.0.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI python-cjson
- Affected
- <= 1.0.5
- Fixed in
- 1.0.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cqmh-mpx2-g633 lists affected ranges: PyPI python-cjson >=0 <1.0.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cqmh-mpx2-g633 lists affected ranges: PyPI python-cjson >=0 <=1.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2010-1666: 1.67% estimated exploitation activity in the next 30 days; percentile 76.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Buffer overflow in Dan Pascu python-cjson 1.0.5, when UCS-4 encoding is enabled, allows context-dependent attackers to cause a denial of service (application crash) or possibly have unspecified other impact via vectors involving crafted Unicode input to the cjson.encode function.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cqmh-mpx2-g633
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-cqmh-mpx2-g633
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-1666 Advisory: Improper Restriction of Operations within the Bounds of a Memory Buffer in python-cjson IDs: CVE-2010-1666, GHSA-cqmh-mpx2-g633 Record: https://patchnext.com/advisories/cve-2010-1666 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-cjson 1.0.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-cjson: affected <= 1.0.5; fixed in 1.0.5.1 ## Suggested inspection (read-only) - `python -m pip show python-cjson`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-cjson. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cqmh-mpx2-g633 (OSV record GHSA-cqmh-mpx2-g633 lists affected ranges: PyPI python-cjson >=0 <1.0.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-cqmh-mpx2-g633 (GitHub-reviewed advisory GHSA-cqmh-mpx2-g633 lists affected ranges: PyPI python-cjson >=0 <=1.0.5) Commands are suggestions: review each one before running it.
Loading voting…