Medium, CVSS 5.4PyPIAmendedPublished
pyRdfa3 Cross-site Scripting vulnerability
CVE-2022-4396 · GHSA-894q-wpg5-mf2h
- Affected
- PyPI pyrdfa3 <= 3.5.3
- Fixed in
- 3.6.2· Vendor fix available
- Issue
- A vulnerability was found in RDFlib pyrdfa3 and classified as problematic. This issue affects the function getoption of the file pyRdfa/init.py. The manipulation leads to cross site scripting. The attack may be initiated remotely. The name of the patch is ffd1d62dd50d5f4190013b39cedcdfbd81f3ce3e. It is recommended to apply a patch to fix this issue. The identifier VDB-215249 was assigned to this vulnerability.
Recommended action: Upgrade to 3.6.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.