Skip to content

← Actionable
Medium, CVSS 5.4amended

pyRdfa3 Cross-site Scripting vulnerability

CVE-2022-4396GHSA-894q-wpg5-mf2h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyrdfa3 3.6.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyrdfa3

    Affected
    <= 3.5.3
    Fixed in
    3.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-4396: 0.61% estimated exploitation activity in the next 30 days; percentile 49.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability was found in RDFlib pyrdfa3 and classified as problematic. This issue affects the function getoption of the file pyRdfa/init.py. The manipulation leads to cross site scripting. The attack may be initiated remotely. The name of the patch is ffd1d62dd50d5f4190013b39cedcdfbd81f3ce3e. It is recommended to apply a patch to fix this issue. The identifier VDB-215249 was assigned to this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-894q-wpg5-mf2h

  2. Revision 1 · created ·

    Published from osv record GHSA-894q-wpg5-mf2h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-4396

Advisory: pyRdfa3 Cross-site Scripting vulnerability
IDs: CVE-2022-4396, GHSA-894q-wpg5-mf2h
Record: https://patchnext.com/advisories/cve-2022-4396 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyrdfa3 3.6.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyrdfa3: affected <= 3.5.3; fixed in 3.6.2

## Suggested inspection (read-only)
- `python -m pip show pyrdfa3`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyrdfa3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-894q-wpg5-mf2h (OSV record GHSA-894q-wpg5-mf2h lists affected ranges: PyPI pyrdfa3 >=0 <3.6.2 (fixed))
- Verified: https://github.com/advisories/GHSA-894q-wpg5-mf2h (GitHub-reviewed advisory GHSA-894q-wpg5-mf2h lists affected ranges: PyPI pyrdfa3 >=0 <=3.5.3)

Commands are suggestions: review each one before running it.

Loading voting…