High, CVSS 7.7PyPIAmendedPublished
pyrage vulnerable to malicious plugin names, recipients, or identities causing arbitrary binary execution
CVE-2024-56327 · GHSA-47h8-jmp3-9f28
- Affected
- PyPI pyrage >= 1.2.0, < 1.2.3
- Fixed in
- 1.2.3· Vendor fix available
- Issue
- pyrage uses the Rust age crate for its underlying operations, and age is vulnerable to GHSA-4fg7-vxc8-qx5w. All details of GHSA-4fg7-vxc8-qx5w are relevant to pyrage for the versions specified in this advisory. See GHSA-4fg7-vxc8-qx5w for full details. Versions of pyrage before 1.2.0 lack plugin support and are therefore not affected. An equivalent issue was fixed in the reference Go implementation of age, see advisory GHSA-32gq-x56h-299c. Thanks to ⬡-49016 for reporting this issue.
Recommended action: Upgrade to 1.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.