Skip to content

← Actionable
High, CVSS 7.7amended

pyrage vulnerable to malicious plugin names, recipients, or identities causing arbitrary binary execution

CVE-2024-56327GHSA-47h8-jmp3-9f28

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyrage 1.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pyrage

    Affected
    >= 1.2.0, < 1.2.3
    Fixed in
    1.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-56327: 0.50% estimated exploitation activity in the next 30 days; percentile 42.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

pyrage uses the Rust age crate for its underlying operations, and age is vulnerable to GHSA-4fg7-vxc8-qx5w. All details of GHSA-4fg7-vxc8-qx5w are relevant to pyrage for the versions specified in this advisory. See GHSA-4fg7-vxc8-qx5w for full details. Versions of pyrage before 1.2.0 lack plugin support and are therefore not affected. An equivalent issue was fixed in the reference Go implementation of age, see advisory GHSA-32gq-x56h-299c. Thanks to ⬡-49016 for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-47h8-jmp3-9f28

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-47h8-jmp3-9f28

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-56327

Advisory: pyrage vulnerable to malicious plugin names, recipients, or identities causing arbitrary binary execution
IDs: CVE-2024-56327, GHSA-47h8-jmp3-9f28
Record: https://patchnext.com/advisories/cve-2024-56327 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyrage 1.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyrage: affected >= 1.2.0, < 1.2.3; fixed in 1.2.3

## Suggested inspection (read-only)
- `python -m pip show pyrage`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyrage.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-47h8-jmp3-9f28 (OSV record GHSA-47h8-jmp3-9f28 lists affected ranges: PyPI pyrage >=1.2.0 <1.2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-47h8-jmp3-9f28 (GitHub-reviewed advisory GHSA-47h8-jmp3-9f28 lists affected ranges: PyPI pyrage >=1.2.0 <1.2.3)

Commands are suggestions: review each one before running it.

Loading voting…