Skip to content

← Public intelligence

PyPI package

pygresql

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPyPIAmendedPublished

    PyGreSQL Might Be Vulnerable to Encoding-Based SQL Injection

    CVE-2009-2940 · GHSA-xv6x-43gq-4hfj

    Affected
    • PyPI pygresql <= 3.8.1; >= 4.0, <= 4.0
    Fixed in
    4.1· Partial vendor fix
    Issue
    PyGreSQL 3.8 did not use PostgreSQL’s safe string and bytea functions in its own escaping functions. As a result, applications written to use PyGreSQL’s escaping functions are vulnerable to SQL injections when processing certain multi-byte character sequences. Because the safe functions require a database connection, to maintain backwards compatibility, pg.escapestring() and pg.escapebytea() are still available, but applications will have to be adjusted to use the new pyobj.escapestring() and pyobj.escapebytea() functions. For example, code containing: should be adjusted to use:

    Recommended action: Upgrade to 4.1; some affected versions have no fix yet, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →