PyGreSQL Might Be Vulnerable to Encoding-Based SQL Injection
CVE-2009-2940GHSA-xv6x-43gq-4hfj
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pygresql
- Affected
- <= 3.8.1>= 4.0, <= 4.0
- Fixed in
- 4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xv6x-43gq-4hfj lists affected ranges: PyPI pygresql >=0 =4.0 <4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xv6x-43gq-4hfj lists affected ranges: PyPI pygresql >=0 =4.0 <=4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2009-2940: 2.70% estimated exploitation activity in the next 30 days; percentile 85.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
PyGreSQL 3.8 did not use PostgreSQL’s safe string and bytea functions in its own escaping functions. As a result, applications written to use PyGreSQL’s escaping functions are vulnerable to SQL injections when processing certain multi-byte character sequences. Because the safe functions require a database connection, to maintain backwards compatibility, pg.escapestring() and pg.escapebytea() are still available, but applications will have to be adjusted to use the new pyobj.escapestring() and pyobj.escapebytea() functions. For example, code containing: should be adjusted to use:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xv6x-43gq-4hfj
- Revision 1 · created ·
Published from osv record GHSA-xv6x-43gq-4hfj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-2940 Advisory: PyGreSQL Might Be Vulnerable to Encoding-Based SQL Injection IDs: CVE-2009-2940, GHSA-xv6x-43gq-4hfj Record: https://patchnext.com/advisories/cve-2009-2940 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: pygresql 4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pygresql: affected <= 3.8.1; >= 4.0, <= 4.0; fixed in 4.1 ## Suggested inspection (read-only) - `python -m pip show pygresql`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pygresql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xv6x-43gq-4hfj (OSV record GHSA-xv6x-43gq-4hfj lists affected ranges: PyPI pygresql >=0 =4.0 <4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-xv6x-43gq-4hfj (GitHub-reviewed advisory GHSA-xv6x-43gq-4hfj lists affected ranges: PyPI pygresql >=0 =4.0 <=4.0) Commands are suggestions: review each one before running it.
Loading voting…