Critical, CVSS 9.3PyPIAmendedPublished
SQL Injection in pycsw
CVE-2016-8640 · GHSA-hg4c-rgvm-964g
- Affected
- PyPI pycsw < 1.8.6; >= 1.10.0, < 1.10.5; >= 2.0.0, < 2.0.2
- Fixed in
- 1.8.61.10.52.0.2· Vendor fix available
- Issue
- A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.
Recommended action: Upgrade to 2.0.2, 1.10.5 or 1.8.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.