SQL Injection in pycsw
CVE-2016-8640GHSA-hg4c-rgvm-964g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pycsw 2.0.2, 1.10.5, 1.8.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pycsw
- Affected
- < 1.8.6>= 1.10.0, < 1.10.5>= 2.0.0, < 2.0.2
- Fixed in
- 1.8.6, 1.10.5, 2.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hg4c-rgvm-964g lists affected ranges: PyPI pycsw >=2.0.0 =0 =1.10.0 <1.10.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hg4c-rgvm-964g lists affected ranges: PyPI pycsw >=0 =1.10.0 =2.0.0 <2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2016-8640: 2.31% estimated exploitation activity in the next 30 days; percentile 83.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hg4c-rgvm-964g
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hg4c-rgvm-964g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-8640 Advisory: SQL Injection in pycsw IDs: CVE-2016-8640, GHSA-hg4c-rgvm-964g Record: https://patchnext.com/advisories/cve-2016-8640 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pycsw 2.0.2, 1.10.5, 1.8.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pycsw: affected < 1.8.6; >= 1.10.0, < 1.10.5; >= 2.0.0, < 2.0.2; fixed in 1.8.6, 1.10.5, 2.0.2 ## Suggested inspection (read-only) - `python -m pip show pycsw`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pycsw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hg4c-rgvm-964g (OSV record GHSA-hg4c-rgvm-964g lists affected ranges: PyPI pycsw >=2.0.0 =0 =1.10.0 <1.10.5 (fixed)) - Verified: https://github.com/advisories/GHSA-hg4c-rgvm-964g (GitHub-reviewed advisory GHSA-hg4c-rgvm-964g lists affected ranges: PyPI pycsw >=0 =1.10.0 =2.0.0 <2.0.2) Commands are suggestions: review each one before running it.
Loading voting…