Skip to content

← Public intelligence

PyPI package

py-cord

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PyPIAmendedPublished

    Bots using py-cord as Discord API wrapper are vulnerable to shutdowns through remote code execution

    CVE-2022-36024 · GHSA-qmhj-m29v-gvmr

    Affected
    • PyPI py-cord >= 2.0.0, <= 2.0.0
    Fixed in
    2.0.1· Vendor fix available
    Issue
    Impact py-cord is a an API wrapper for Discord written in Python. Bots using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the application.commands scope without the bot scope. Currently, it appears that all public bots that use slash commands are affected. Patches This issue has been patched in version 2.0.1. Workarounds There are currently no recommended workarounds - please upgrade to a patched version. References https://github.com/Pycord-Development/pycord/pull/1568 For more information If you have any questions or comments about this advisory: Open an issue in our GitHub Email us at support@pycord.dev

    Recommended action: Upgrade to 2.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →