Bots using py-cord as Discord API wrapper are vulnerable to shutdowns through remote code execution
CVE-2022-36024GHSA-qmhj-m29v-gvmr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (py-cord 2.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI py-cord
- Affected
- >= 2.0.0, <= 2.0.0
- Fixed in
- 2.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qmhj-m29v-gvmr lists affected ranges: PyPI py-cord >=2.0.0 <2.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qmhj-m29v-gvmr lists affected ranges: PyPI py-cord >=2.0.0 <=2.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-36024: 0.80% estimated exploitation activity in the next 30 days; percentile 56.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact py-cord is a an API wrapper for Discord written in Python. Bots using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the application.commands scope without the bot scope. Currently, it appears that all public bots that use slash commands are affected. Patches This issue has been patched in version 2.0.1. Workarounds There are currently no recommended workarounds - please upgrade to a patched version. References https://github.com/Pycord-Development/pycord/pull/1568 For more information If you have any questions or comments about this advisory: Open an issue in our GitHub Email us at support@pycord.dev
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qmhj-m29v-gvmr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qmhj-m29v-gvmr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-36024 Advisory: Bots using py-cord as Discord API wrapper are vulnerable to shutdowns through remote code execution IDs: CVE-2022-36024, GHSA-qmhj-m29v-gvmr Record: https://patchnext.com/advisories/cve-2022-36024 (revision 3, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: py-cord 2.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI py-cord: affected >= 2.0.0, <= 2.0.0; fixed in 2.0.1 ## Suggested inspection (read-only) - `python -m pip show py-cord`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on py-cord. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qmhj-m29v-gvmr (OSV record GHSA-qmhj-m29v-gvmr lists affected ranges: PyPI py-cord >=2.0.0 <2.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-qmhj-m29v-gvmr (GitHub-reviewed advisory GHSA-qmhj-m29v-gvmr lists affected ranges: PyPI py-cord >=2.0.0 <=2.0.0) Commands are suggestions: review each one before running it.
Loading voting…