High, CVSS 8.7PyPIAmendedPublished
py vulnerable to Regular Expression Denial of Service
CVE-2020-29651 · GHSA-hj5v-574p-mj7c
- Affected
- PyPI py < 1.10.0
- Fixed in
- 1.10.0· Vendor fix available
- Issue
- A denial of service via regular expression in the py.path.svnwc component of py (aka python-py) through 1.9.0 could be used by attackers to cause a compute-time denial of service attack by supplying malicious input to the blame functionality.
Recommended action: Upgrade to 1.10.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.