py vulnerable to Regular Expression Denial of Service
CVE-2020-29651GHSA-hj5v-574p-mj7c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (py 1.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI py
- Affected
- < 1.10.0
- Fixed in
- 1.10.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hj5v-574p-mj7c lists affected ranges: PyPI py >=0 <1.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hj5v-574p-mj7c lists affected ranges: PyPI py >=0 <1.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2020-29651: 4.66% estimated exploitation activity in the next 30 days; percentile 91.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A denial of service via regular expression in the py.path.svnwc component of py (aka python-py) through 1.9.0 could be used by attackers to cause a compute-time denial of service attack by supplying malicious input to the blame functionality.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-hj5v-574p-mj7c
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-hj5v-574p-mj7c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-29651 Advisory: py vulnerable to Regular Expression Denial of Service IDs: CVE-2020-29651, GHSA-hj5v-574p-mj7c Record: https://patchnext.com/advisories/cve-2020-29651 (revision 3, source checked 26 Oct 2026, 13:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: py 1.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI py: affected < 1.10.0; fixed in 1.10.0 ## Suggested inspection (read-only) - `python -m pip show py`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on py. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hj5v-574p-mj7c (OSV record GHSA-hj5v-574p-mj7c lists affected ranges: PyPI py >=0 <1.10.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hj5v-574p-mj7c (GitHub-reviewed advisory GHSA-hj5v-574p-mj7c lists affected ranges: PyPI py >=0 <1.10.0) Commands are suggestions: review each one before running it.
Loading voting…