High, CVSS 8.7PyPIAmendedPublished
NYUCCL psiTurk IS vulnerable to Improper Neutralization of Special Elements
CVE-2021-4315 · GHSA-9mq4-9556-6qxq
- Affected
- PyPI psiturk < 3.2.1
- Fixed in
- 3.2.1· Vendor fix available
- Issue
- A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.
Recommended action: Upgrade to 3.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.