NYUCCL psiTurk IS vulnerable to Improper Neutralization of Special Elements
CVE-2021-4315GHSA-9mq4-9556-6qxq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (psiturk 3.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI psiturk
- Affected
- < 3.2.1
- Fixed in
- 3.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9mq4-9556-6qxq lists affected ranges: PyPI psiturk >=0 <3.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9mq4-9556-6qxq lists affected ranges: PyPI psiturk >=0 <3.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-4315: 0.91% estimated exploitation activity in the next 30 days; percentile 59.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9mq4-9556-6qxq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9mq4-9556-6qxq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-4315 Advisory: NYUCCL psiTurk IS vulnerable to Improper Neutralization of Special Elements IDs: CVE-2021-4315, GHSA-9mq4-9556-6qxq Record: https://patchnext.com/advisories/cve-2021-4315 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: psiturk 3.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI psiturk: affected < 3.2.1; fixed in 3.2.1 ## Suggested inspection (read-only) - `python -m pip show psiturk`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on psiturk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9mq4-9556-6qxq (OSV record GHSA-9mq4-9556-6qxq lists affected ranges: PyPI psiturk >=0 <3.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9mq4-9556-6qxq (GitHub-reviewed advisory GHSA-9mq4-9556-6qxq lists affected ranges: PyPI psiturk >=0 <3.2.1) Commands are suggestions: review each one before running it.
Loading voting…