Skip to content

← Public intelligence

PyPI package

pgadmin4

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

28 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1PyPIAmendedPublished

    pgAdmin 4 Open Redirect vulnerability

    CVE-2023-22298 · GHSA-894c-rg7f-3c62

    Affected
    • PyPI pgadmin4 < 6.14
    Fixed in
    6.14· Vendor fix available
    Issue
    Open redirect vulnerability in pgAdmin 4 versions prior to v6.14 allows a remote unauthenticated attacker to redirect a user to an arbitrary web site and conduct a phishing attack by having a user to access a specially crafted URL.

    Recommended action: Upgrade to 6.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.8PyPIAmendedPublished

    pgadmin4 vulnerable to Code Injection

    CVE-2022-4223 · GHSA-3v6v-2x6p-32mc

    Affected
    • PyPI pgadmin4 < 6.17
    Fixed in
    6.17· Vendor fix available
    Issue
    The pgAdmin server includes an HTTP API that is intended to be used to validate the path a user selects to external PostgreSQL utilities such as pgdump and pgrestore. The utility is executed by the server to determine what PostgreSQL version it is from. Versions of pgAdmin prior to 6.17 failed to properly secure this API, which could allow an unauthenticated user to call it with a path of their choosing, such as a UNC path to a server they control on a Windows machine. This would cause an appropriately named executable in the target path to be executed by the pgAdmin server.

    Recommended action: Upgrade to 6.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.5PyPIAmendedPublished

    pgAdmin 4 Path Traversal vulnerability

    CVE-2022-0959 · GHSA-cr8c-972v-rmp3

    Affected
    • PyPI pgadmin4 < 6.7
    Fixed in
    6.7· Vendor fix available
    Issue
    When run in server mode, pgAdmin 4 allows users to store files on the server under individual storage directories. Files such as SQL scripts may be uploaded through the user interface. The URI to which upload requests are made fails to validate the upload path to prevent path traversal techniques being used to store files outside of the storage directory. A malicious, but authorised and authenticated user can construct an HTTP request using their existing CSRF token and session cookie to manually upload files to any location that the operating system user account under which pgAdmin is running has permission to write.

    Recommended action: Upgrade to 6.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →