Skip to content

← Actionable
High, CVSS 8.8amended

pgadmin4 vulnerable to Code Injection

CVE-2022-4223GHSA-3v6v-2x6p-32mc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pgadmin4 6.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-4223: 80.07% estimated exploitation activity in the next 30 days; percentile 99.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The pgAdmin server includes an HTTP API that is intended to be used to validate the path a user selects to external PostgreSQL utilities such as pgdump and pgrestore. The utility is executed by the server to determine what PostgreSQL version it is from. Versions of pgAdmin prior to 6.17 failed to properly secure this API, which could allow an unauthenticated user to call it with a path of their choosing, such as a UNC path to a server they control on a Windows machine. This would cause an appropriately named executable in the target path to be executed by the pgAdmin server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3v6v-2x6p-32mc

  2. Revision 1 · created ·

    Published from osv record GHSA-3v6v-2x6p-32mc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-4223

Advisory: pgadmin4 vulnerable to Code Injection
IDs: CVE-2022-4223, GHSA-3v6v-2x6p-32mc
Record: https://patchnext.com/advisories/cve-2022-4223 (revision 2, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pgadmin4 6.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pgadmin4: affected < 6.17; fixed in 6.17

## Suggested inspection (read-only)
- `python -m pip show pgadmin4`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pgadmin4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3v6v-2x6p-32mc (OSV record GHSA-3v6v-2x6p-32mc lists affected ranges: PyPI pgadmin4 >=0 <6.17 (fixed))
- Verified: https://github.com/advisories/GHSA-3v6v-2x6p-32mc (GitHub-reviewed advisory GHSA-3v6v-2x6p-32mc lists affected ranges: PyPI pgadmin4 >=0 <6.17)

Commands are suggestions: review each one before running it.

Loading voting…