Skip to content

← Public intelligence

PyPI package

parsl

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3PyPIAmendedPublished

    Parsl Monitoring Visualization Vulnerable to SQL Injection

    CVE-2026-21892 · GHSA-f2mf-q878-gh58

    Affected
    • PyPI parsl < 2026.1.5
    Fixed in
    2026.1.5· Vendor fix available
    Issue
    Affected Product: Parsl (Python Parallel Scripting Library) Component: parsl.monitoring.visualization Vulnerability Type: SQL Injection (CWE-89) Severity: High (CVSS Rating Recommended: 7.5 - 8.6) URL: https://github.com/Parsl/parsl/blob/master/parsl/monitoring/visualization/views.py Summary A SQL Injection vulnerability exists in the parsl-visualize component of the Parsl library. The application constructs SQL queries using unsafe string formatting (Python % operator) with user-supplied input (workflowid) directly from URL routes. This allows an unauthenticated attacker with access to the visualization dashboard to inject arbitrary SQL commands, potentially leading to data exfiltration or denial of service against the monitoring database. Root Cause Analysis The vulnerability is located in parsl/monitoring/visualization/views.py. Multiple route handlers take the workflowid parameter from the URL and inject it directly into a raw SQL query string without sanitization or…

    Recommended action: Upgrade to 2026.1.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →