Skip to content

← Actionable
Medium, CVSS 5.3amended

Parsl Monitoring Visualization Vulnerable to SQL Injection

CVE-2026-21892GHSA-f2mf-q878-gh58

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (parsl 2026.1.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI parsl

    Affected
    < 2026.1.5
    Fixed in
    2026.1.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-21892: 0.27% estimated exploitation activity in the next 30 days; percentile 20.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected Product: Parsl (Python Parallel Scripting Library) Component: parsl.monitoring.visualization Vulnerability Type: SQL Injection (CWE-89) Severity: High (CVSS Rating Recommended: 7.5 - 8.6) URL: https://github.com/Parsl/parsl/blob/master/parsl/monitoring/visualization/views.py Summary A SQL Injection vulnerability exists in the parsl-visualize component of the Parsl library. The application constructs SQL queries using unsafe string formatting (Python % operator) with user-supplied input (workflowid) directly from URL routes. This allows an unauthenticated attacker with access to the visualization dashboard to inject arbitrary SQL commands, potentially leading to data exfiltration or denial of service against the monitoring database. Root Cause Analysis The vulnerability is located in parsl/monitoring/visualization/views.py. Multiple route handlers take the workflowid parameter from the URL and inject it directly into a raw SQL query string without sanitization or…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f2mf-q878-gh58

  2. Revision 1 · created ·

    Published from osv record GHSA-f2mf-q878-gh58

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-21892

Advisory: Parsl Monitoring Visualization Vulnerable to SQL Injection
IDs: CVE-2026-21892, GHSA-f2mf-q878-gh58
Record: https://patchnext.com/advisories/cve-2026-21892 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: parsl 2026.1.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI parsl: affected < 2026.1.5; fixed in 2026.1.5

## Suggested inspection (read-only)
- `python -m pip show parsl`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on parsl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f2mf-q878-gh58 (OSV record GHSA-f2mf-q878-gh58 lists affected ranges: PyPI parsl >=0 <2026.01.05 (fixed))
- Verified: https://github.com/advisories/GHSA-f2mf-q878-gh58 (GitHub-reviewed advisory GHSA-f2mf-q878-gh58 lists affected ranges: PyPI parsl >=0 <2026.1.5)

Commands are suggestions: review each one before running it.

Loading voting…