High, CVSS 7.1PyPIAmendedPublished
oslo.middleware Information Disclosure vulnerability
CVE-2017-2592 · GHSA-xcp8-hh74-f6mc
- Affected
- PyPI oslo-middleware < 3.8.1; >= 3.9.0, < 3.19.1; >= 3.20.0, < 3.23.1; >= 3.9.0, < 3.19.1; < 3.8.1; >= 3.20.0, < 3.23.1
- Fixed in
- 3.8.13.23.13.19.1· Vendor fix available
- Issue
- python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure. Software using the CatchError class could include sensitive values in a traceback's error message. System users could exploit this flaw to obtain sensitive information from OpenStack component error logs (for example, keystone tokens).
Recommended action: Upgrade to 3.23.1, 3.19.1 or 3.8.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.