oslo.middleware Information Disclosure vulnerability
CVE-2017-2592GHSA-xcp8-hh74-f6mc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (oslo-middleware 3.23.1, 3.19.1, 3.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI oslo-middleware
- Affected
- < 3.8.1>= 3.9.0, < 3.19.1>= 3.20.0, < 3.23.1>= 3.9.0, < 3.19.1< 3.8.1>= 3.20.0, < 3.23.1
- Fixed in
- 3.8.1, 3.23.1, 3.19.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xcp8-hh74-f6mc lists affected ranges: PyPI oslo-middleware >=3.9.0 =0 =3.20.0 <3.23.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xcp8-hh74-f6mc lists affected ranges: PyPI oslo-middleware >=0 =3.9.0 =3.20.0 =3.9.0 =0 =3.20.0 <3.23.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2017-2592: 0.44% estimated exploitation activity in the next 30 days; percentile 38.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure. Software using the CatchError class could include sensitive values in a traceback's error message. System users could exploit this flaw to obtain sensitive information from OpenStack component error logs (for example, keystone tokens).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xcp8-hh74-f6mc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-xcp8-hh74-f6mc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-2592 Advisory: oslo.middleware Information Disclosure vulnerability IDs: CVE-2017-2592, GHSA-xcp8-hh74-f6mc Record: https://patchnext.com/advisories/cve-2017-2592 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: oslo-middleware 3.23.1, 3.19.1, 3.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI oslo-middleware: affected < 3.8.1; >= 3.9.0, < 3.19.1; >= 3.20.0, < 3.23.1; >= 3.9.0, < 3.19.1; < 3.8.1; >= 3.20.0, < 3.23.1; fixed in 3.8.1, 3.23.1, 3.19.1 ## Suggested inspection (read-only) - `python -m pip show oslo-middleware`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on oslo-middleware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xcp8-hh74-f6mc (OSV record GHSA-xcp8-hh74-f6mc lists affected ranges: PyPI oslo-middleware >=3.9.0 =0 =3.20.0 <3.23.1 (fixed)) - Verified: https://github.com/advisories/GHSA-xcp8-hh74-f6mc (GitHub-reviewed advisory GHSA-xcp8-hh74-f6mc lists affected ranges: PyPI oslo-middleware >=0 =3.9.0 =3.20.0 =3.9.0 =0 =3.20.0 <3.23.1) Commands are suggestions: review each one before running it.
Loading voting…