Low, CVSS 1.9PyPIAmendedPublished
AcademySoftwareFoundation OpenColorIO has an out-of-bounds vulnerability
CVE-2025-15506 · GHSA-m86r-wr74-693h
- Affected
- PyPI opencolorio < 2.5.1
- Fixed in
- 2.5.1· Vendor fix available
- Issue
- A vulnerability was found in AcademySoftwareFoundation OpenColorIO up to 2.5.0. This issue affects the function ConvertToRegularExpression of the file src/OpenColorIO/FileRules.cpp. Performing a manipulation results in out-of-bounds read. The attack needs to be approached locally. The exploit has been made public and could be used. The patch is named ebdbb75123c9d5f4643e041314e2bc988a13f20d. To fix this issue, it is recommended to deploy a patch. The fix was added to the 2.5.1 milestone.
Recommended action: Upgrade to 2.5.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.