AcademySoftwareFoundation OpenColorIO has an out-of-bounds vulnerability
CVE-2025-15506GHSA-m86r-wr74-693h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (opencolorio 2.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI opencolorio
- Affected
- < 2.5.1
- Fixed in
- 2.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m86r-wr74-693h lists affected ranges: PyPI opencolorio >=0 <2.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m86r-wr74-693h lists affected ranges: PyPI opencolorio >=0 <2.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-15506: 0.18% estimated exploitation activity in the next 30 days; percentile 7.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability was found in AcademySoftwareFoundation OpenColorIO up to 2.5.0. This issue affects the function ConvertToRegularExpression of the file src/OpenColorIO/FileRules.cpp. Performing a manipulation results in out-of-bounds read. The attack needs to be approached locally. The exploit has been made public and could be used. The patch is named ebdbb75123c9d5f4643e041314e2bc988a13f20d. To fix this issue, it is recommended to deploy a patch. The fix was added to the 2.5.1 milestone.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m86r-wr74-693h
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m86r-wr74-693h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-15506 Advisory: AcademySoftwareFoundation OpenColorIO has an out-of-bounds vulnerability IDs: CVE-2025-15506, GHSA-m86r-wr74-693h Record: https://patchnext.com/advisories/cve-2025-15506 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: opencolorio 2.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI opencolorio: affected < 2.5.1; fixed in 2.5.1 ## Suggested inspection (read-only) - `python -m pip show opencolorio`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on opencolorio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m86r-wr74-693h (OSV record GHSA-m86r-wr74-693h lists affected ranges: PyPI opencolorio >=0 <2.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-m86r-wr74-693h (GitHub-reviewed advisory GHSA-m86r-wr74-693h lists affected ranges: PyPI opencolorio >=0 <2.5.1) Commands are suggestions: review each one before running it.
Loading voting…