Skip to content

← Public intelligence

PyPI package

onefuzz

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.5PyPIAmendedPublished

    Improper Authorization and Origin Validation Error in OneFuzz

    CVE-2021-37705 · GHSA-q5vh-6whw-x745

    Affected
    • PyPI onefuzz >= 2.12.0, < 2.31.0
    Fixed in
    2.31.0· Vendor fix available
    Issue
    Impact Starting with OneFuzz 2.12.0 or greater, an incomplete authorization check allows an authenticated user from any Azure Active Directory tenant to make authorized API calls to a vulnerable OneFuzz instance. To be vulnerable, a OneFuzz deployment must be: Version 2.12.0 or greater Deployed with the non-default --multitenantdomain option This can result in read/write access to private data such as: Software vulnerability and crash information Security testing tools Proprietary code and symbols Via authorized API calls, this also enables tampering with existing data and unauthorized code execution on Azure compute resources. Patches This issue is resolved starting in release 2.31.0, via the addition of application-level check of the bearer token's issuer against an administrator-configured allowlist. Workarounds Users can restrict access to the tenant of a deployed OneFuzz instance < 2.31.0 by redeploying in the default configuration, which omits the --multitenantdomain option.…

    Recommended action: Upgrade to 2.31.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →