Skip to content

← Actionable
Critical, CVSS 9.5amended

Improper Authorization and Origin Validation Error in OneFuzz

CVE-2021-37705GHSA-q5vh-6whw-x745

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (onefuzz 2.31.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI onefuzz

    Affected
    >= 2.12.0, < 2.31.0
    Fixed in
    2.31.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L · score source
EPSS
  • CVE-2021-37705: 2.42% estimated exploitation activity in the next 30 days; percentile 84.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Starting with OneFuzz 2.12.0 or greater, an incomplete authorization check allows an authenticated user from any Azure Active Directory tenant to make authorized API calls to a vulnerable OneFuzz instance. To be vulnerable, a OneFuzz deployment must be: Version 2.12.0 or greater Deployed with the non-default --multitenantdomain option This can result in read/write access to private data such as: Software vulnerability and crash information Security testing tools Proprietary code and symbols Via authorized API calls, this also enables tampering with existing data and unauthorized code execution on Azure compute resources. Patches This issue is resolved starting in release 2.31.0, via the addition of application-level check of the bearer token's issuer against an administrator-configured allowlist. Workarounds Users can restrict access to the tenant of a deployed OneFuzz instance < 2.31.0 by redeploying in the default configuration, which omits the --multitenantdomain option.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-q5vh-6whw-x745

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-q5vh-6whw-x745

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-37705

Advisory: Improper Authorization and Origin Validation Error in OneFuzz
IDs: CVE-2021-37705, GHSA-q5vh-6whw-x745
Record: https://patchnext.com/advisories/cve-2021-37705 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: onefuzz 2.31.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI onefuzz: affected >= 2.12.0, < 2.31.0; fixed in 2.31.0

## Suggested inspection (read-only)
- `python -m pip show onefuzz`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on onefuzz.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q5vh-6whw-x745 (OSV record GHSA-q5vh-6whw-x745 lists affected ranges: PyPI onefuzz >=2.12.0 <2.31.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q5vh-6whw-x745 (GitHub-reviewed advisory GHSA-q5vh-6whw-x745 lists affected ranges: PyPI onefuzz >=2.12.0 <2.31.0)

Commands are suggestions: review each one before running it.

Loading voting…