Critical, CVSS 9.8PyPIAmendedPublished
Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library
CVE-2023-39631 · GHSA-f73w-4m7g-ch9x
- Affected
- PyPI numexpr < 2.8.5
- Fixed in
- 2.8.5· Vendor fix available
- Issue
- An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr library. Patches: Released in v.0.0.308. numexpr dependency is optional for langchain.
Recommended action: Upgrade to 2.8.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.