Skip to content

← Actionable
Critical, CVSS 9.8amended

Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library

CVE-2023-39631GHSA-f73w-4m7g-ch9x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (numexpr 2.8.5; langchain 0.0.308), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI numexpr

    Affected
    < 2.8.5
    Fixed in
    2.8.5
  • PyPI langchain

    Affected
    < 0.0.308
    Fixed in
    0.0.308

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-39631: 1.60% estimated exploitation activity in the next 30 days; percentile 75.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr library. Patches: Released in v.0.0.308. numexpr dependency is optional for langchain.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f73w-4m7g-ch9x

  2. Revision 1 · created ·

    Published from osv record GHSA-f73w-4m7g-ch9x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-39631

Advisory: Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library
IDs: CVE-2023-39631, GHSA-f73w-4m7g-ch9x
Record: https://patchnext.com/advisories/cve-2023-39631 (revision 2, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: numexpr 2.8.5; langchain 0.0.308. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI numexpr: affected < 2.8.5; fixed in 2.8.5
- PyPI langchain: affected < 0.0.308; fixed in 0.0.308

## Suggested inspection (read-only)
- `python -m pip show numexpr`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show langchain`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on numexpr, langchain.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f73w-4m7g-ch9x (OSV record GHSA-f73w-4m7g-ch9x lists affected ranges: PyPI langchain >=0 =0 <2.8.5 (fixed))
- Verified: https://github.com/advisories/GHSA-f73w-4m7g-ch9x (GitHub-reviewed advisory GHSA-f73w-4m7g-ch9x lists affected ranges: PyPI langchain >=0 =0 <2.8.5)

Commands are suggestions: review each one before running it.

Loading voting…