Skip to content

← Public intelligence

PyPI package

multipart

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PyPIAmendedPublished

    multipart vulnerable to ReDoS in parse_options_header()

    CVE-2026-28356 · GHSA-p2m9-wcp5-6qw3

    Affected
    • PyPI multipart >= 1.3.0, < 1.3.1; < 1.2.2
    Fixed in
    1.2.21.3.1· Vendor fix available
    Issue
    The parseoptionsheader() function in multipart.py uses a regular expression with an ambiguous alternation, which can cause exponential backtracking (ReDoS) when parsing maliciously crafted HTTP or multipart segment headers. This can be abused for denial of service (DoS) attacks against web applications using this library to parse request headers or multipart/form-data streams. Impact Any WSGI or ASGI application using multipart.parseformdata() directly or indirectly (e.g. while parsing multipart/form-data streams) is vulnerable. The slow-down is significant enough to block request handling threads for multiple seconds per request. Affected versions All versions up to and including 1.3.0 are affected. The issue is fixed in 1.2.2, 1.3.1 and 1.4.0-dev.

    Recommended action: Upgrade to 1.3.1 or 1.2.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →