Skip to content

← Actionable
High, CVSS 7.5amended

multipart vulnerable to ReDoS in parse_options_header()

CVE-2026-28356GHSA-p2m9-wcp5-6qw3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (multipart 1.3.1, 1.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI multipart

    Affected
    >= 1.3.0, < 1.3.1< 1.2.2
    Fixed in
    1.2.2, 1.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-28356: 0.76% estimated exploitation activity in the next 30 days; percentile 55.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The parseoptionsheader() function in multipart.py uses a regular expression with an ambiguous alternation, which can cause exponential backtracking (ReDoS) when parsing maliciously crafted HTTP or multipart segment headers. This can be abused for denial of service (DoS) attacks against web applications using this library to parse request headers or multipart/form-data streams. Impact Any WSGI or ASGI application using multipart.parseformdata() directly or indirectly (e.g. while parsing multipart/form-data streams) is vulnerable. The slow-down is significant enough to block request handling threads for multiple seconds per request. Affected versions All versions up to and including 1.3.0 are affected. The issue is fixed in 1.2.2, 1.3.1 and 1.4.0-dev.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p2m9-wcp5-6qw3

  2. Revision 1 · created ·

    Published from osv record GHSA-p2m9-wcp5-6qw3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-28356

Advisory: multipart vulnerable to ReDoS in `parse_options_header()`
IDs: CVE-2026-28356, GHSA-p2m9-wcp5-6qw3
Record: https://patchnext.com/advisories/cve-2026-28356 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: multipart 1.3.1, 1.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI multipart: affected >= 1.3.0, < 1.3.1; < 1.2.2; fixed in 1.2.2, 1.3.1

## Suggested inspection (read-only)
- `python -m pip show multipart`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on multipart.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p2m9-wcp5-6qw3 (OSV record GHSA-p2m9-wcp5-6qw3 lists affected ranges: PyPI multipart >=1.3.0 =0 <1.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-p2m9-wcp5-6qw3 (GitHub-reviewed advisory GHSA-p2m9-wcp5-6qw3 lists affected ranges: PyPI multipart >=1.3.0 =0 <1.2.2)

Commands are suggestions: review each one before running it.

Loading voting…