High, CVSS 7.2PyPIAmendedPublished
Improper validation in meraki
GHSA-6x4h-9622-fqr6
- Affected
- PyPI meraki < 1.40.1
- Fixed in
- 1.40.1· Vendor fix available
- Issue
- aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Improper validation made it possible for an attacker to modify the HTTP request (e.g. to insert a new header) or create a new HTTP request if the attacker controls the HTTP version. The vulnerability only occurs if the attacker can control the HTTP version of the request. This issue has been patched in version 3.9.0. meraki from version 1.40.1 requires aiohttp 3.9.0
Recommended action: Upgrade to 1.40.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.